404 invoiceplane (1.4.8)

Sup everyone

Everytime I want to setup the newest version of invoiceplane, I got redirected to
home/flexpay/public_html/welcome
The code stands in the root (public_html) under an subdomain

<IfModule mod_rewrite.c>

  RewriteEngine On
  #RewriteBase /subfolder
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]

  ## Remove the hash in front of the following two lines if you want to force HTTPS
  #RewriteCond %{HTTPS} off
  #RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

</IfModule>

I rewrote my code, and UN-commend the rewrite base but it still don’t work.
I also have tried to set RewriteBase to /home2/flexpay/public_html

If it’s not working simply disable the .htaccess,
It’s no essential feature.

If I remove the .htaccess file
I get the 404 page off my server
and still links me to /home/flexpay/public_html/welcome