Updated to 1.4.8 -- UpdateCheck still shows old version

Thanks for the great app.

I followed the upgrade procedure to do a long-overdue upgrade from 1.1.0 to 1.4.8. Setup seemed to go OK, however UpdateCheck still shows the old version (1.1.0).

Per this thread I manually changed the data type of the column item_name in the ip_invoice_items table from VARCHAR(100) to VARCHAR(500).

In this older thread w/ a similar issue you said to run:

INSERT INTO `ip_versions` (`version_id`, `version_date_applied`, `version_file`, `version_sql_errors`) VALUES (7, '1424534471', '006_1.2.0.sql', 0);

I looked but couldn’t find a similar SQL statement for 1.4.8. What’s the best way to resolve?

BTW, running on localhost via WAMP 3.0.0 / Apache 2.4.17 / PHP 7.0.0


Updated Version Number/Details
OK, I think I got it figured out and fixed. Corrections of any errors made here are welcomed! :bulb:

To update the version number and related fields I ran this SQL:

INSERT INTO `ip_versions` (`version_id`, `version_date_applied`, `version_file`, `version_sql_errors`) VALUES (21, '1472919878', '020_1.4.8.sql', 0)
  • The version_id is the total number of *.sql files in \application\modules\setup\sql
  • The version_date_applied is the current php time()
  • The version_file is the newest *.sql file in \application\modules\setup\sql
  • version_sql_errors is, well, hopefully correct!

Database Not Updated During Upgrade (Couldn’t Save Invoices/Quotes)
I haven’t looked into why (i.e., gone through application\logs), but the database updates didn’t happen. So there were a number of tables/columns that were either missing or incorrect.

This meant that clicking Save in a quote or invoice would cause the app to hang, displaying the spinning gear icon indefinitely. Reloading the page at that point would indicate the record had been saved.

To correct this I ran, sequentially, the SQL statements in \application\modules\setup\sql. And everything seems to be working correctly–so far!

1 Like