404 Error after upgrade from 1.4.7 - 1.4.8 and fresh install 1.4.8

Hi i got this problem only on version 1.4.8

I tried upgrading and also fresh install but both get the same error

"http://www.enaga.my/home/d/public_html/enaga.my/invoices/index.php/sessions/login was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Below is the link to the admin console:
http://www.enaga.my/invoices

I have contacted the support on my host, but they also didnt knew what the problem is.

And they would like an opinion from the developer first to identify the problem.

Thanks

Did you get this after updating?

Please also see this thread: Wrong URL in 1.4.7

Hi kovah, thanks for your fast reply, this is a fresh installed. and about that thread, i already read it and tried but, it might repaired the link problem, but then it causes the other problem to occured. and when i repaired another problem come up. As this is only a trial site, if you like a ftp access, i would happy to provide you with the access.

Hi Kovah,

It seems somehow i found the problem and the solution to this kind of problem. You see the problem are existed in application>config>config.php

on the line 18
$config['base_url'] = $config['protocol'] . ($_SERVER['HTTP_HOST'] ? $_SERVER['HTTP_HOST'] : $_SERVER['SERVER_NAME']) . URL_SUBFOLDER;

There are two way to solve the 404 issues,
If you install it directly to your main domain directory (“www.domain.com” or “invoice.domain.com”) then you will need to remove the “. URL_SUBFOLDER”. Start from the “.” until the word “R”. And then save.

If you install it on the directory inside your main domain ( “www.domain.com/invoice”) then you will need to remove the " URL_SUBFOLDER". Only the URL_SUBFOLDER" and do not touch the “.” and replace it with your directory name along with this ’ '. For example if your installed directory is “www.domain.com/receipt” you will need to put it like this:

$config['base_url'] = $config['protocol'] . ($_SERVER['HTTP_HOST'] ? $_SERVER['HTTP_HOST'] : $_SERVER['SERVER_NAME']) . '/receipt' ;

It seems somehow Kovah, the URL_SUBFOLDER didnt work as it is. Some hosting like stablehost unable to translate this kind of URL_SUBFOLDER. They sure that it didnt cause by their server.

Hope this could help anyone that facing this problem. If you have any question, you may ask below.

IM SORRY, this fix may causes other issues such as unable to save or create an invoice. Please avoid from using my fix, unless you can used this and improvise it in anyway. For the time being, im reverting back to 1.4.7.