Stuck on choose language

Doing a new install of 1.4.8

I go to

Choose English, click continue

Not Found
The requested URL /setup/language was not found on this server.

If you can help me I will be grateful.

Thank you.



 <Directory /home/dan/www/website/invoice/>
       Options Indexes FollowSymLinks
       AllowOverride All
       Order allow,deny
       allow from all


  RewriteEngine On
  RewriteBase //invoice
 # RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . index.php [L]

mod_rewrite is enabled and shows in PHPtest page.

Please change this to

RewriteBase /invoice

and remove the hash before the third line. Why is it there anyway?

Thank you for your reply.

I had that double “//” there since earlier the url was dropping the “/” but I dont seem to have that issue any more.

The hash was there before for a reason but it seems to not effect what I have right now.

This is my .htaccess file now.

  RewriteEngine On
  RewriteBase /invoice
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . index.php [L]

I am still getting the same result

after clicking setup in

Not Found

The requested URL /setup/language was not found on this server.

Its like as if it is not going through /invoice and just /setup/language.

or /setup/language is not available?

In that case I would just remove the .htaccess file and try again with index.php as it’s not necessary to use this for the application.

BTW I am running this version,
PHP Version 7.0.8-0ubuntu0.16.04.2

So I reinstated the files under /invoice and added /invoice to the htaccess file

I go to “

The page starts to load and the url changes to “

the “/” before invoice goes away and it cant load the page.

so I add a “/” hit enter and it loads the setup page…

so I click “setup” and the page loads and the url takes away the “/” agian… what is going on here? :sweat:

Some kind of misconfiguration or something. Did you tried without the .htaccess file?

Yes, I moved the htaccess out and gave it a try and got the same result.

Please also check this post: Wrong URL in 1.4.7

We are getting closer now…
The URL is no longer dropping the forward slash before the subfolder after deleting URL_SUBFOLDER from config.php.

now I just 404 out becasue after clicking setup it drops the subfolder from the URL and loads:

instead of

If you only use this URL you could use this in the config file:

$config['base_url'] = '';

This Works! I made it to the Prerequisites page.


        Welcome to InvoicePlane! Any issue listed below must be resolved before the installation can continue.

                             PHP appears to meet the installation requirement
                                 There seems to be no timezone configured. Please check date.timezone in your php configuration. Otherwise UTC will be selected.
                             ./uploads is not writable
                                 ./uploads/temp is not writable
                                 ./uploads/archive is not writable
                                 ./uploads/customer_files is not writable
                                 ./application/config/ is not writable
                                 ./application/helpers/mpdf/tmp is not writable
                                 ./application/helpers/mpdf/ttfontdata is not writable
                                 ./application/helpers/mpdf/graph_cache is not writable
                                 ./application/logs is not writable

But not a permanent solution since I would be accessing this on other devices outside my home network.

Thanks for your persistence thus far I am ging to see if i can find the location of these files and change the permissions.

Maybe you unzipped the files as root? Then the owner = root so you should change it to your username (or the httpd/apache user in some cases) in order for it to work. Is the “chown -R” command for that.

Yes, I unzipped the files in windows and uploaded them via Filezilla. Ill try chown -R when i am home from work.

I had this problem too.
I tried everything - changed htaccess, config.php, it drove me nuts.
Finally i renamed the htaccess file and disabled it.
I was able to go through the setup procedure and complete the upgrade.
Then i logged in normally.

Im not sure if the htaccess file is required for the future - but im too scared to re-enable it.
Also the Version Number has stayed at the old version - which was 1.4.4

The .htaccess file is not required at all. It just removed index.php from all URLs. Nothing more.

1 Like

Hey all,

I wanted to let you know that I just had to edit the timezone in my php.ini and the permissions errors had went away.

; Module Settings ;

[CLI Server]
; Whether the CLI web server uses ANSI color coding in its terminal output.
cli_server.color = On

; Defines the default timezone used by the date functions
date.timezone = America/New_York