Blank page when trying to email

I just upgraded from FusionInvoice to InvoicePlane, and now it’s all gone to pieces :sob:

Debugging is enabled, the page just goes blank when I try to send an email.

This is from the log from ONE send event:

Undefined property: stdClass::$invoice_status 

Could you please post the current status of the invoice you want to email.

It was in Draft when I first tried, now it’s sitting on sent.

I just changed it to “Draft” again, then tried to resend. Same thing.

Just tried to sent an “Invoice Paid” email.

Blank screen again. :frowning:

I just trashed the entire thing, and reimported from scratch, even removed the custom fields, etc. Exactly the same error. May as well stick to FusionInvoice for now as it works.

Sad to hear that it’s not working for you.

Could you please explain the following details:

  • Did you updated your PDF templates after you migrated from FusionInvoice?
  • Are you able to download the invoice PDF?

No I didn’t update the templates, I deleted all the files from Fusion and put a clean copy of InvoicePlane in place.
I am able to download the PDF templates and they seem to work ok, no issues.

OK, could you please post some more details about your server?

HI Kovah, please see below. Anything else you would like to know?

Apache Version
PHP Version
MySQL Version
Operating System

I had an issue on another site with mod_security, thought this may be causing it, so I turned if off and did the whole process again. Still no luck. Blank pages, and lines and line of errors in the log.

Hi, any feedback or updates on this

It seems it was a SMTP issue, using PHPSend is working.


I’ve been having the exact same problem over the smtp mails.

I start from scratch, nothing imported, pdf’s working fine.

About my server setup:
My log:

Any help would be great!

Thanks in advance.

Regards from Chile!


I’m also having issues with PDF files not showing and mails not sending.
I hope you find the origin of the issue.

Please update to version 1.4.9 and make sure that you downloaded it from the website.
Both email sending and PDF generation was uodated in this version.

Hi Kovah,

thanks for answering (so quickly)!
It’s a treat when the lead developer invests so much in community!

That said, I am running the newest version and I got it from the site here.
I realized I didn’t provide much feedback on what my system is…

So I’m running it on a typical LAMP-stack (at Siteground) in a shared hosting environment. I tried both PHP7 and PHP 5.6
I’ve already set error logging to level 4, but I don’t get useful information. (maybe you could)

Just as a sidenote, sending out a quote worked just fine. Because of this, I don’t think it’s an issue with the server.

Thanks for maintaining and upgrading a great product!

Interesting you are on a shared Siteground account. I had the blank page when emailing invoices on a Siteground account also. I ended up rolling back to v1.4.4 and emails work again. 1.4.6 and 1.4.8 both did the blank page for me. I couldn’t determine if it was IP or Siteground causing the issue.

Hi Cabji,

thanks for your feedback. I indeed tried out a similar setup on a different hosting provider ( - one of the low budget solutions). All worked fine there. I’ll be contacting Siteground and ask them about it.

I could bet that Siteground blocks a specific port that would be needed to send emails properly.

Hi, is there a difference between sending quotes and sending invoices? Because quotes go out just fine and the pdf generate too.

Also I can’t imagine a blocked port causing pdf not to generate.


I figured out the error happened when uploading or decompressing. For some reason there were some files that got corrupt.
Siteground delivered great service, they dug into the issue and looked into the code till they found the lines where something was not found. Kudos for Siteground for diving into this head first. This was not something they had to support, but they did anyway!

That’s interesting! Do you know which files were corrupt?