Installation stuck at select Language

I am trying to get Invoice plane installed and have tried it in the document root as well as a sub folder which is my preference. I am able to get to the setup page where it wants me to select a language. Once I do this, nothing happens. So I am stuck at select language.

I am seeing the error:
File does not exist: /var/www/html/assets, referer:

Right now I have the program installed in the directory “doc_root”/invoices. I modified the config.php per the directions and removed the index.php.

modified my .htaccess files as follows:

<IfModule mod_rewrite.c>
# Remove index.php
RewriteEngine on
RewriteBase /invoices
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

# Enable the following if you want to force HTTPS access:
#RewriteCond %{SERVER_PORT} 80
#RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L]

I have made the changes in the httpd.conf file:
Options Indexes FollowSymLinks
AllowOverride ALL
Order allow,deny
Allow from all

And just to be sure added the following to the httpd.conf file.

<Directory "/var/www/html/invoices">
  Options Indexes FollowSymLinks
    AllowOverride All

ReWritemod is enabled as I am using it for other tasks as well.

Any help would be greatly appreciated.


Is it working without modifying the .htaccess? Because this is not needed by default.

I put everything back to original in the document_root directory did not modify the htaccess file and tried. I get to the setup screen, click on setup and then to choose language and the install will not go any further.


So, I tracked this down to line 432 in security.php. After turning on the logs to debug I see

" ERROR - 2016-07-01 12:20:35 --> Severity: Warning --> preg_replace_callback(): Compilation failed: unrecognized character after (?< at offset 5 /var/www/html/system/core/Security.php 432"

Bypassing this call, I get to the next screen, which tells me all is good with the exception I need to load PHP5.4 instead of PHP5.3.

Going to try that now and see if PHP5.4 clears up the error.


PHP 5.3? This version is unsupported for more than a year now and a big security risk!

This is resolved. It was because I was using PHP5.3. Thanks, you can close this thread. My version of Centos 5 took some work to get PHP5.4 up and running.