Invoice numbering format

I need to change the numbering format of the invoice number. For exaple, instead of having “Invoice # 9”, I need to have it read as “Invoice # 000009”. Editing the “left pad” in Settings>Invoice Groups to 00000 resets to 0 on saving the edit.

Any ideas?

shouldn’t you rather use “left pad: 6” for 6 digits?

The setting describes how many digits should be displayed and fills with leading zeroes when the number to display has less digits.