Special character problem invoice select tab


I having problems with the special characters, when fill words as:

Â, ñ (Cañaveral, caña, Iñigo, Ângel)

Witch accented works correctly, as:


When create a customer work as well, not problem with character but when create a invoice and select a customer show the problem with the characters, if you select then you go to your customer list, that create a new customer with the strange characters, then go back to the invoice and edit and choose the correct customer, show the correct character codification, the problem seems like be on the invoice create select tab.

I see a post that a similar problem that was fixed in the 1.4 version but not see anymore, can anybody help me? or have a similar issue?


I’m running 1.4.6 version, is a fresh installation.

Thank you.

I had the error also.
It is not a DB problem.

This is my way to solv the problem.
It was an IP-301 dissolved, but in the current version, it is again htmlentities () instead of htmlspecialchars ().


 64 foreach ($clients as $client){
 65    echo "<option value='".htmlspecialchars($client->client_name)."' ";
 66    if ($client_name == $client->client_name) echo 'selected';
 67    echo ">".htmlspecialchars($client->client_name)."</option>";
 68 }


61 foreach ($clients as $client){
62     echo "<option value='".htmlspecialchars($client->client_name)."' ";
63     if ($client_name == $client->client_name) echo 'selected';
64     echo ">".htmlspecialchars($client->client_name)."</option>";
65 }


1 Like

Hello Araziel,

Thank you by your suggest, I find other bug, when the name of the custom have “'”, in the tab when you select, the save button not work.

I have tested it with the following custom.

000 Test Kunde äüö’

I can create the Custom.
I can change invoices.

What process do you mean?

Sorry by the delay, in you have a customer with name by example:

L’Rodriguez Servicios

If you go to the tab invoice -> create invoice, then select this client, you will see that the software create a new client with name ->L<-, and not take the correct customer.

Thank you.