Recurring invoices - 404 error

Hi Everyone,

I just want to ask how to achieve the recurring invoices feature after spending 2 weeks time but still can’t see any movement.

I did go through the wiki and some external discussions such as [Solved] Cron Job Error: 404 NOT FOUND but still can’t locate my problem.

I set up invoice plane on both localhost (XAMPP) and hosting provider Netvirtue (installed it by one-click softaculous) but the recurring feature is not working on neither side, while all other features are working as expected.

my invoiceplane can be accessed like mydomain.com/invoiceplane/index.php

The things I checked / confirmed are:
1 - mydomain.com has changed to my domain name
2 - http://mydomain.com/invoices/cron/recur/my-cron-key >> invoices has been changed to my sub folder name such as invoiceplane
3 - cron key have been generated a few times from Setting and replaced my-cron-key
4 - removed the # in httaccess file as it is running in a sub-directory
5 - in case I have similar issue like the one reported in this community, I did try localhost/invoiceplane/invoces/cron/recur/LU2TNi2g40s1swTe
but still no luck

The problem is
1 - if opening the url like localhost/invoiceplane/cron/recur/LU2TNi2g40s1swTe
I got error:
object not found! Error 404
Similar problem on Netvirtue

2 - Cron job running report on Netvirtue is showing error 404 such as
Status: 404 Not Found
X-Powered-By: PHP/5.5.34
Content-type: text/html

No input file specified.

I really appreciate if you could shed light on this.

Cheers.

This URL is wrong and not set up responding to the wiki.
You have to change it to domain.com/invoiceplane/invoices/cron/recur/LU2TNi2g40s1swT

Hi Kovah,

Thank you for the quick response but it doesn’t help.

See the following cron feedback

Cron -@syd-s33e /usr/bin/php public_html/invoice/invoices/cron/recur/5d1SRZrtEqthsF6U
Status: 404 Not Found
X-Powered-By: PHP/5.5.34
Content-type: text/html

No input file specified.

Giving enough information and hope you don’t mind, here is the URL for the service
http://-.com.au/invoice/

so as per your suggestion, the URL I set should be the one below but still not good (confirmed again from Setting the key is 5d1SRZrtEqthsF6U)
http://my-domain.com/invoice/invoices/cron/recur/5d1SRZrtEqthsF6U

Do you have any suggestion?

Thanks again.

Is the app running with index.php in the URL or not? If yes you have to add it to the cron URL too

Hi Kovash,

Thank you for checking this.

I tested that the app can run with / without index.php
http://-.com.au/invoice/index.php

I am not sure if I misunderstood your suggestion about “add it to the cron” URL but can you please explain a bit more?

Thanks again.

Hi Kovash,

Thank you for the advice.

my-domain.com/invoice/index.php/invoices/cron/recur/key

does help.

Please do not forget to change your API Key since you posted the key here.