Error in Prerequisites on Centos

I am trying to install Invoice Plane on centos Server. It holds on the Prerequisites page as shown in the screen shot below:

I gave all the permissions to the Application and uploads folder. As you can see from the screenshot above that i have 777 access to application and uploads:

I even tried to change the Owner of the folder to Apache but it did not solve the problem. I tried to delete the folder and unzip again but i am facing the same problem every time. Not sure how to solve it.

Please Let me know if you have any idea what is wrong.

Thanks in Advance.

The requirements does not state that you should make the application folder writable. You should make application/config and other subfolders writable.

I have made application folder writable recursively… see Below

I have the same problem with centos 7

Anyone have any idea on this?

Did you ever find a solution to this? I’m running into the same problem on Fedora 23. After unzipping the directories appear to have the proper permissions. After getting the exact same message as you I also gave everything full permissions to everyone just to see if I could get past this step. No luck.


Okay, upon further digging I’m assuming is has something to do with the “APPPATH” variable not getting set correctly.


Yes. I got it working. It was Actually SELinux blocking Apache’s permission to write to folders.

So i did:

sudo chcon -t httpd_sys_rw_content_t /data/www/html/sites/mysite -R

You can read further details on:

Hope this will help everyone :slight_smile:

1 Like

Thank you very much, that did it.

I’ll add this to the wiki as fast as possible. Thanks for the info.