Unable To Download PDF From Guest URL

I’ve discovered a bug regarding the download of PDF files from the guest url. When I generate a quote, the PDF that is emailed generates perfectly. But if the recipient visits the guest URL and attempts to download the PDF there, Invoice Plane throws the following error:

	An Error Was Encountered
	Unable to load the requested file: quote_templates/pdf/.php	

I located a similar issue while searching here, [Solved] PDF download issue, but mbstring isn’t an issue on my server, I don’t believe. PHPINFO shows that it is enabled.

Any idea what I might be doing wrong?



It’s pretty weird that it says .php without a filename…
Do you have any other logs you could post? There should be some available from the /application/logs directory of InvoicePlane.

Can do. Should I sanitize it and throw the relevant bits in a Pastebin, or would it be best to email it to you directly?



Here’s the sanitized log:

Could you check if the file /home/USERNAME/ar.DOMAINNAME.com/application/helpers/mpdf/ttfontdata/dejavuserifcondensed.mtx.php exists? If yes, are the file permissions correct? This could maybe lead to the problems.

Confirmed that file exists, 0644. Directory permissions in that path are all 0755.

Can you check the settings, section quotes, setting “Default Public Template”? If this is empty I get the same error.

That setting is not empty, it is set to default.

Just to be sure - which version of InvoicePlane do you use?
Did you modify any file of the installation?
Please test this: set the setting “Default Public Template” to the empty value, save, then restore to “default”. Does it make any difference?

It’s version 1.2.0.

No files modified.

Setting “Default Public Template” to empty, then reverting to “default” value seems to have fixed it.

Thank you both for this project, and for working so diligently to help me resolve my issue!


This is not an official released version.
Please reinstall with v 1.1.1

Oh, no…did I install the wrong version? I’m not sure how that happened.

Very sorry if I’ve caused any trouble.

No problem.
Just install the version you can download from the website or the one from the master branch from the repository.

Be sure to create a backup first, there were some database changes from 1.1.* zu 1.2.0.