Upstream sent too big header

When doing any operation to quote that already have lots (read more than 10 or so) products, the operation fails. The error log file shows:

upstream sent too big header while reading response header from upstream, client xxx.xxx.xxx.xxx, server: serveraddress.com, requestL "POST /ip/index/php/quotes/ajax/save HTTP/1.1", upstream: "http://xxx.xxx.xxx.xxx:8080/ip/index.php/quotes/ajax/save", host: "serveraddress.com", referrer: http://serveraddress.com/ip/index.php/quotes/view/16"

The error above happens when I try to add a product to the quote. But if I try to save the quote I get the spinning gear the same error.

I tried increasing the buffer sizes using these instructions, but it still shows the same error.

Have you seen this before? I tried searching and could not find anything related to this.

Which buffers did you increase and how much?
And did you restarted the webserver?

This is my current nginx configuration.

fastcgi_buffers 8 32k;
fastcgi_buffer_size 64k;

right now I can’t even load Invoice Plane. Its giving me this error in the main page.

I think I was able to solve it using this:

I spoke too soon. Im not getting the error now, but the changes to the quote, like adding a new product, are not being saved.

Inexplicably, the problem solved itself while I was trying to debug it… It “feeled” like there was some kind of delay in the database operations… the db was being updated with the new stuff but the front end didnt displayed correctly. Is there some kind of cache system in Invoice Plane that I don’t know about?

No, InvoicePlane uses no caches.

If the problem persists please also take a look at this topic:

Thats what I did. I’m having a different problem now, but I think its not limited to Invoice Plane. Im noticing delays in other apps too… Consider this one solved.

Thanks!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.