Problem with sending invoice-mail

Hi all,

I’m running Centos 7 (Apache 2.4.18, PHP 5.5.30, MariaDB 5.5.41).
And I’ve install InvoicePlane v1.4.6.

If I try to send invoice-mail to my clients with [at] address, they do not receive my emails.

But if I send invoice-mail to my clients with [at] address, they do receive my email, but the sender email address shows: username[at] instead of info[at]

Is this a known bug? How can I fix those issues?

Thanks in advance!

Pinotje from The Netherlands

Is sounds like you are having issues with the “From” header. Gmail is dropping the emails because it fails to verify that you are allowed to send from The ISP is not as strict on checking this and allows the emails to be delivered. Remember that big name emails services, Gmail, Aol, Yahoo, Outlook will be harder on spam and incorrect email headers will be flagged and the emails dropped.

Try sending a test invoice to you will get an auto generated email, this should help you track down the issue.

Hi evelio204,

Thanks for you reply, I did a test on and my score is 10/10.

If I send a email from my hostingprovider’s webmail to a [at] emailaddress, then there is no problem.
But if I send it from InvoicePlane, then they do not receive my invoice-email.


On the InvoicePlane settings page which method are you using to send email?


I tried PHPmail and Sendmail.

When using those and having your hosting provider send the email you will have the FROM address mismatch, which causes Gmail to drop the email or flag it as spam. It sounds like your provider is overriding your FROM address which is why some recipeints see “username[at]”.

Unless you can work with your provider to stop this behaviour, my recommendation in order to get the FROM address to be Is to switch to using the SMTP method with a transactional email provider such as SendGrid or SparkPost.

Hi evelio,

I’m running my own hosting-provider (CentOS7+DirectAdmin on VPS).
Do you know how to disable overriding the FROM address?

ps. Before when I run CentOS6, there was no problem with sending invoice-email from InvoicePlane.

I am not familiar with CentOS setup of InvoicePlane. Hopefully someone else on the forum is able to help. I currently have setup InvoicePlane on Windows Server with IIS.

Hi evelio,

I already found the problem:

I simply added:

untrusted_set_sender = *

to: /etc/exim.conf