Blank screen on configure database

I am trying to upgrade from InvoicePlane 1.4.4 to 1.4.6. I have downloaded and extracted the files into the filesystem. When attempting to run setup, I get to the configure database screen, which is blank.

I have taken a look at a similar issue, issue 1467, but in that case the MYSQL module was not installed in PHP. I am sure that is not my issue, especially since 1.4.4 is running without issue. My logs have been pasted to

I am running:
CentOS Linux release 7.2.1511
PHP 5.6.16
mysql Ver 15.1 Distrib 10.0.23-MariaDB, for Linux (x86_64) using readline 5.1

You run InvoicePlane without problems and it takes you to the database upgrade screen sich is blank?

Could you please check if there is a database.php in the applications/config folder?
The setup should not take you to the configure screen and should ein without problems AS there were no SQL changes made.

Which module do you use in your php.ini? mysql or mysqli? This has to be the same in your database.php file. If in doubt, try the mysqli module, the other one has been deprecated for long now and with php7 support (if you plan on upgrading) is completely removed so you’d have to switch anyway.

Yes, the database.php file does exist and is populated.

I tried @Laurens suggestion to change $db[‘default’][‘dbdriver’] = ‘mysql’; to $db[‘default’][‘dbdriver’] = ‘mysqli’; and receive the blank screen on any access. Mysql is being used in my php.ini file.

Nevermind. I found out it was an issue with my PHP configuration.

Could you post this misconfiguration for other users?

I am actually not sure what fixed it. I rebuilt using EasyApache in Cpanel and the issue was resolved.

This topic was automatically closed 23 hours after the last reply. New replies are no longer allowed.