SMTP Error sending a bill

Hi!

I have introduced all my smtp information correctly and I tried diferent things but I can’t resolve it.

Could you help me please?

That’t the error:

SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Did you read the information written here: https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#smtp-error-could-not-connect-to-smtp-host ?
I think this is very helpful.

InvoicePlane itself does not affect the usage of the PhpMailer library, the only thing we can do is updating the library which will be done with the next version.

Yes, it’s the standard. I have connected to the server correctly but it is a problem of Invoice Plane or CodeIgniter in the connexion SMTP.

I also have the same problem. I posted my issue here a few days back but didn’t geet a response. Likewise I know I have used the correct credentials for my serrver but also get a connection error.

The thing is that I can’t reproduce any SMTP errors. I tried both with Mandrill and my own SMTP.
The code thats sends the mail is the same like in the PhpMailer documentation.

I had the same error too.

The issue seems to be with the password containing certain special characters such as ^ or % once I removed these from my password it worked (other characters such as @ still work).

I was clued into this when in the configuration after I saved, then the hidden password wasn’t showing enough characters.

1 Like

I had the same issue sending via my smtp server also tried updating to latest phpmailer as the version included is older. none of it worked I eventually changed the mailer component to swiftmailer and works fine now. Seems to be an issue with phpmailers and authentication against smtp servers requiring non tls based authentication.

1 Like

David, how did you change the mailer component? Can you post a guide?

hi, i still learning this apps, and i get similar problems when i try using smtp zoho or gmail,
but i solved this problem by downgrade php version, from 7 to 5.6

hope this help

I’m getting same issue. when trying to change email settings i get:

Fatal error: Call to undefined function random_bytes() in /var/www/html/invoice/application/libraries/Cryptor.php on line 90
A PHP Error was encountered
Severity: Error
Message: Call to undefined function random_bytes()
Filename: libraries/Cryptor.php
Line Number: 90
Backtrace:

InvoicePlane requires php-openssl to be installed and activated on your web server.
https://wiki.invoiceplane.com/en/1.5/getting-started/requirements

this is enabled on the server.

#php -v
PHP 5.6.30-0+deb8u1 (cli) (built: Feb 8 2017 08:50:21)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright © 1999-2016, by Zend Technologies

php -i | grep -i openssl

openssl
OpenSSL support => enabled
OpenSSL Library Version => OpenSSL 1.0.1t 3 May 2016
OpenSSL Header Version => OpenSSL 1.0.1t 3 May 2016
Openssl default config => /usr/lib/ssl/openssl.cnf
openssl.cafile => no value => no value
openssl.capath => no value => no value
OpenSSL support => enabled

Resolved by upgrading PHP to 7.0. Nothing else worked…

Hi ccrraazzyy2,

I have the same error when configuring SMTP with password. I tried to upgrade my PHP version from 5.6 to 7.0 but I get a lot of depencies errors when uninstalling PHP 5.6

Do you have an advice for me ?

apt-get remove libapache2-mod-php5 php5 php5-cli php5-common php5-curl php5-gd php5-json php5-mcrypt php5-mysql php5-readline php5-recode php5-xmlrpc
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
libc-bin : Depends: libc6 (< 2.20) but 2.21-0ubuntu4 is to be installed
php-gettext : Depends: php5 but it is not going to be installed or
php5-cli but it is not going to be installed
phpmyadmin : Depends: libapache2-mod-php5 but it is not going to be installed or
libapache2-mod-php5filter but it is not going to be installed or
php5-cgi but it is not going to be installed or
php5-fpm but it is not going to be installed or
php5 but it is not going to be installed
Depends: php5-mysql or
php5-mysqli but it is not installable or
php5-mysqlnd but it is not going to be installed
Depends: php5-mcrypt but it is not going to be installed
Depends: php5-json but it is not going to be installed
Recommends: php5-gd but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Whats is your distro?

Try to remove all php related using apt-get remove php* then reinstall, but you may enable php7 repo to this works.

Srry for my bad english :slight_smile:

By the way, the Call to undefined function random_bytes() error will be solved with the next version 1.5.3.

using php7 fixed the issue.

same problem after upgrading from 1.4.10 to 1.5.2

SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting