SMTP Mail Settings

My mail settings are set to “SMTP” and I’ve checked and rechecked the credentials I used, but everytime I try to send email, I get rediected to the login screen. What am I missing?

I am also getting this on one of my installations.

I used to use PHPMailer to send email but that recently stopped working. It says “Mail sent successfully” but it doesn’t send.
The invoiceplane installation is hosted on shared account.
I tried TLS security with all the settings from siteground’s email account advisor utility and TLS times out in the browser.
SSL returns to the login screen.
No security returns to login screen.
Tried different SMTP hosts but they all timeout the same as TLS.

Is there any way to see a log of what is going on? The invoiceplane logging doesn’t show me anything to do with the SMTP activity.

PS: I have another siteground account and invoiceplane is working on that account, sending email fine with phpmailer.

PPS: Just triple checked all the credentials and I can’t see anything wrong with my settings.

PPPS: mbsarino - can you post which version of InvoicePlane you are using? My problematic install is reporting as v1.3.3 even though I did an update to 1.4.6 today. When running the /setup after the upgrade procedure, my invoiceplane gives me the error discussed here: Restore Database from SQL file into New Installation so there’s that. I don’t know if that is connected to this problem, maybe you have the same thing going on?

PPPPS: Upgraded to 1.4.6 by copying the database to a new database, wiping the old one, running setup so 1.4.6 makes the tables again, then pushed the data back into the new database. Still no luck with mailing options. PHPMailer claims “success” but not, sendmail simply isnt working, SMTP with credentials using my webhost’s SMTP returns me to the login page and using GMail PHP Mailer spits out “SMTP connect() failed”. Changed PHP version to 5.4.45 and allowed less secure app access on the gmail account. No luck still.