Login logo and Favicon appearing properly

I uploaded a logo image for the login screen but no matter the size, it always gets resized to a small logo as seen in the screenshot.

How do I get it to appear in its original size?

Also, how do I change the favicon and page title from that of Invoice plane to my own site title and icon?

Thanks for the help!!

The page title can be changed in the general settings in “Custom Page Title”.
For the logo try using the custom.css file in the assets/default/css folder to manually set the width and height for the logo.

How about the favicon.ico? I change the favicon.ico in the assets/default folder but the icon on the page title bar hasnt changed.

Likely to be a cache issue, try deleting your cache for the past 24 hours, optionally view it by another browser, my icon updates in chrome but not internet explorer so this is why i suggest this.

Hope this helps

Thank Lee

@Kovah how do I modify the custom.css file? My apologies in advance as I am not a coder. Thanks!

You can just use a text editor. You’ll have to edit this file to change the details (located on your webserver). You’ll need to know at least some basic CSS. http://www.w3schools.com/css/css_dimension.asp

Actually this works for every page EXCEPT the log in page. The log in page title is always “InvoicePlace”, no matter what your custom title it. Once you log in you see the custom title.

Continuing the discussion from Login logo and Favicon appearing properly:

Add this to your custom.css:

img {
  width: 1000%;
  height: auto;

It should do the trick.

I think this will break image displaying all over the application. There is a custom class for the login logo:

.login-logo {
    width: 500px !important;
    height: auto;

Thanks @Kovah! That did the trick!

My favicon is still not appearing. I have also changed the Default title on the settings menu but the login screen still says Invoiceplane. Is there something else I need to do to change this?

If you’ve done your facivon properly, it’ll show up eventually. With cache, these things sometimes take a few days.

As far as I can tell, there is currently no way to change the Log In page title. Maybe submit a request to @Kovah?

@AFSADAM: What do you mean “If you have done your favicon properly”? I took a jpg file and got that converted to an ico file online. Are there “restrictions” on the ico file needed?

On the Login page title, I have solved it already. Apparently the Login page had the tags on them set manually to “Invoiceplaje”

From memory, your favicon needs to be a .png for this software? in your assets/default/img folder

Where did you change the title on the login page?

<link rel="icon" type="image/png" href="https://yourdomain.com/assets/default/img/favicon.png">

@Kovah: where do I change that line of code? I uploaded a favicon.png file to /assets/default/img/ but it still doesnt show.

Only replace the image. Don’t forget to clear the browser cache.

I’ve already replaced the image and cleared my browser cache. No go,

And you definitely used a .png not a .ico?

Try checking with a different browser or on a different computer. But like I said earlier, sometimes it can take a few days to see the change on your computer, even if you have cleared the cache.

That soud pretty weird now. If you replaced the file there should be no reason why the old one is still displayed.