Configure Database Setup Server Error


#1

Hello,

I’m getting a server error 500 after I entered the database information. Windows firewalls is off.

Installed on
Windows 7
PHP 7.0.0 (Comes with mcrypt and MySQL libraries)

I have looked at the solution in the following topic:


However the php used comes with mysqli by default. I did try to replace mysqli by MySQL just to test it but this did not work.

Here are the logs after I changed the logs_threshold = 2
http://hastebin.com/fisobotiyu.coffee

I have also deleted the contents of the Invoice directory and restarted the setup. I still get stuck at the same spot.

Here are the parameters for the database.php from the \Invoice\application\config
$db[‘default’][‘hostname’] = ‘localhost’;
$db[‘default’][‘username’] = ‘crutherford’;
$db[‘default’][‘password’] = ‘password’;
$db[‘default’][‘database’] = ‘invoice’;
$db[‘default’][‘dbdriver’] = ‘mysqli’;
$db[‘default’][‘dbprefix’] = ‘’;
$db[‘default’][‘pconnect’] = TRUE;
$db[‘default’][‘db_debug’] = TRUE;
$db[‘default’][‘cache_on’] = FALSE;
$db[‘default’][‘cachedir’] = ‘’;
$db[‘default’][‘char_set’] = ‘utf8’;
$db[‘default’][‘dbcollat’] = ‘utf8_general_ci’;
$db[‘default’][‘swap_pre’] = ‘’;
$db[‘default’][‘autoinit’] = TRUE;
$db[‘default’][‘stricton’] = FALSE;


#2

Normally all 500 errors should be logged in the web server error logs. Please locate them and locate the error based on the number and time.


#3

I have verified those logs, but I don’t understand it.
I cleared the logs, reaccessed the site and theres not much in it. I attached the link with the logs when I hit the error.
http://hastebin.com/eyamixizoy.apache

Edit:
So I found that its a Module or ISAPI error. I doubt you would know why this occurs? It really only happens on the configure_database part. Only after the database information has been inserted. If I clear everything and restart that page displays fine.
IIS 7.0, IIS 7.5, and IIS 8.0 define the following HTTP status codes that indicate a more specific cause of a 500 error:
500.0 - Module or ISAPI error occurred.


#4

Hm… unfortunately I’m not familiar with IIS.


#5

I ended up downgrading the php version from 7 to 5.3. It works now. I’m unsure why it didn’t work with version 7. I might end up creating a new environment to test it with version 7 more thoroughly.


#6

5.3? Ugh…
Please do not use this version in production, okay. 5.6 should work too.


#7

I scraped, the vm and rebuilt it using php 5.6 almost everything is working as far as i can tell. However there is only one issue that I’m running into now. I’ll be making another topic for that.


#8

Installation
For those of you comfortable with installing web applications, installing InvoicePlane should take 5 minutes or less.

Download and extract the archive.
Create an empty database on your web server.
Upload the files to your web server, either into its own subdirectory or into the public root of the web server.
Run the InvoicePlane installer from your web browser and follow his instructions: http://your-domain.com/index.php/setup
Once the installer finished, the installation is complete and you may log into InvoicePlane using the email address and password you have chosen during the installation.

Remove index.php from the URL
Make sure that mod_rewrite is enabled on your web server.
Open the file /application/config/config.php
Search for $config[‘index_page’] = ‘index.php’; in this file and replace it with $config[‘index_page’] = ‘’;
Rename the htaccess file to .htaccess
Now open http://your-domain.com/setup to run the setup.

Run InvoicePlane in a sub directory
If you want to run InvoicePlane in a sub directory (e.g. http://yourdomain.com/invoices/) you have to modify the .htaccess file which is located in the root directory. You must add the line

RewriteBase /sub-directory
where sub-directory is the directory you want to use. The content of the file should look like this:

RewriteEngine on
RewriteBase /sub-directory
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]


#9

Check the DB port number in your ipconfig file.