Installation file missing

I’ve changed my .htaccess to the what the Wiki says, to use it in a sub-directory. However, when I attempt to run the setup, I get a 404. I have no setup folder or file to run. PHP, PHPbb, Joomla, WordPress, everything runs flawlessly…except Invoice Plane.

When I key in: mydomain/invoicing/ I get an error:

A Database Error Occurred
Unable to connect to your database server using the provided settings.
Filename: DRIVE:\mydomain\invoicing\system\database\DB_driver.php
Line Number: 125

Where do I find the setup files?

As described in the wiki you should open the after copying all files. Which means in your case with the sub directory

And I get a 404: File/Directory not found. So, something has to be missing from the Download Package. IIS cannot run something that doesn’t exist.

Yeah, there are some files missing. I have however decided to go a different route. I am using WordPress and some plugin’s as my invoicing system as this doesn’t really work too well.

Maybe you just didn’t upload all the files or your server is still running on PHP 5.3, which won’t work either. :smiley:

IIS is running 5.4. And I did download and extract the files into the sub-directory on the drive. So it came straight from the download. It seems to be a common occurrence that Invoice Plane didn’t include all the files. And for that, I won’t use Invoice Plane.

:exclamation: :exclamation: :exclamation: No! There are no files missing! :exclamation: :exclamation: :exclamation:

The wiki clearly states that your webserver (which is Windows IIS) needs mod_rewrite enabled and configured that the system is able to load the .htaccess file. Please look at the Windows IIS documentation on how to configure the server that mod_rewrite works.
This is a standard function for web servers for several years now and just because your web server is not configured properly it means that InvoicePlane is a bad application.

1 Like

My mod_rewrite is enabled and working flawlessly with PHPbb, WordPress, and Joomla…

There has to be a script/redirect/directory missing. In order for any web server to run a directory…it has to exist. domain/setup does not exist. Nor is there any script that says: when user keys in domain/setup run this.

I’ve installed many PHP scripts, and there is always a redirect to the install file or the install file is present and clearly labeled. And it modifies the .htaccess on it’s own.

I’d recommend rewriting some of your files to include it, and maybe make it a little more user friendly to install. I’ve ran into multiple people in the past few days who gave up and went to WordPress and Sprout Invoices.

It’s a shame really, because so far Invoice Plane seems to be the nicest looking System.

The app is working without any problems on thousands of servers. If it’s not working on your server it’s not our fault. so we will not rewrite anything, it would be a waste of time.
By the way: the .htaccess file we are using is exactly the same Wordpress generates. Nothing special. If you were already able to work with Wordpress InvoicePlane should work too.

1 Like

I have Wordpress, Joomla, Invision Power Board, VBulletin and many other things work and was trying to run this software on a machine that houses thousands of people. I too was also getting the same exact error here “404 not found” running apache on CentOS and mod_rewrite is enabled and working because it takes away the index.php file when you navigate to it.

Just because it works on a thousand servers doesn’t mean it is necessarily “our” fault. Maybe there is something that you didn’t account for in your code for certain scenarios. Not saying this is true, in this scenario - just that that logic is slightly flawed. Though it is reasonable to assume - it doesn’t make it fact.

As Nathan stated, the setup directory does not exist. Now, this is normal behavior as to how mod_rewrite is changing the URL format.

Here is the listing of files immediately after unzipping:

[eNkrypt@kratos invoice]$ ls -al
total 12548
drwxrwxr-x  6 eNkrypt eNkrypt     4096 Dec 29 14:23 .
drwxr-xr-x 28 eNkrypt eNkrypt     4096 Dec 29 11:24 ..
drwxr-xr-x 16 eNkrypt eNkrypt     4096 Dec 13 04:07 application
drwxr-xr-x  3 eNkrypt eNkrypt       20 Dec 13 04:07 assets
-rwxr-xr-x  1 eNkrypt eNkrypt     4030 Dec 13 04:07
-rwxr-xr-x  1 eNkrypt eNkrypt      306 Dec 13 04:07 .gitignore
-rwxr-xr-x  1 eNkrypt eNkrypt      290 Dec 13 04:07 .htaccess
-rwxr-xr-x  1 eNkrypt eNkrypt     6470 Dec 13 04:07 index.php
-rwxr-xr-x  1 eNkrypt eNkrypt     4996 Dec 13 04:07 license.txt
-rwxr-xr-x  1 eNkrypt eNkrypt     1741 Dec 13 04:07
-rwxr-xr-x  1 eNkrypt eNkrypt       25 Dec 13 04:07 robots.txt
drwxr-xr-x  8 eNkrypt eNkrypt      122 Dec 13 04:07 system
drwxr-xr-x  6 eNkrypt eNkrypt      129 Dec 13 04:07 uploads
-rw-rw-r--  1 eNkrypt eNkrypt 12796516 Dec 13 13:16 v1.4.4

(Notice that the zip file you download from does not have an extension - so I used the unix “unzip” command to unarchive it.)

Be sure to check your error log for apache rewrite. In my case I found that apache was having issues because of a misconfiguration of a particular domain:

[access_compat:error] [pid 14767] [client] AH01797: client denied by server configuration: /home/eNkrypt/domains/public_html/invoice/application/modules/setup

This was caused because I have a subdomain setup pointing to a folder within a domain. Navigating to the folder works fine while waiting for the DNS to resolve for the subdomain. However, I forgot that the way apache works is if I am specifying inside the httpd.conf file that the subdomain has access to this directory, then I try to run a rule on it from another directive inside of a separate virtual host then you are going to get permission problems.

I have it working now. Moral of the story CHECK YOUR LOGS!!!