Site stuck because of an error - when creating invoices


I have a problem with a self hosted invoice plane installation, it is creating the error “Site Stuck because of an error” when i try to create a new invoice.

Version is 1.5.9 - have tried updating to 1.6.1 and then am unable to connect to the database and proceed through setup.

Restored the site back to the original version, in fact restored back to the last day it was working (date of last invoice) 4th June - and still not working (same error).

Is anyone able to offer any advice on this issue?



Make a new issue for this one, it can easily be fixed

Ok, the first advice is to open up your developer console of your chrome or firefox browser.
I think it’s the Console tab and i hope there’s a bunch of red lines there.
Show screenshot of that please.

Next, go to your Network tab. Same deal: show screenshot of the red lines there.

Now open up /application/logs/ and see if there’s a log file there.
Try to find the last piece of the log.
Let’s hope there’s a nice error message there.

Mote to self: you have this:
'loading_error' => 'It seems that the application stuck because of an error.'
And it’s in this file: /application/modules/layout/views/includes/fullpage-loader.php

Turns out someone had removed the number for my “Days til overdue” Field in the invoice config, Needs to be a number in there, cant be left blank!

As soon as i put a number in, i could create invoices again!

Still cant upgrade to 1.6.1 though, run setup, get to database config, cant connect to database! Have tried the #before and also the 's before and after the password - no success - will probably open this as a new ticket!

Thanks for your help guys, who knew a missing expiry (in days) number could break the whole thing!

It’s a great idea to open it as a new Forum post.
Subject can be:
In InvoicePlane 1.6.1 i cannot connect to the database (something like that)

The response would have been:
Put your password in between quotes

For example my password is i_cannot_wait_for_invoiceplane_v2

And since 1.6.1 in my ipconfig.php it says:

1 Like