No layout after upgrade after new install 1.6.1

I got no layour after install 1.6.1.
the page looks like this:
2024-03-02 at 19.46.06

from log it said:

ERROR - 2024-03-02 19:28:13 --> Could not find the language line ""

The lanuague I choose is English, and from the Language folder seems under english folder , there is no file called form_validation_lang.php file ,compare with other language folder.

Hi @Foloco,
The best thing you can do is download the .zil file from the website.

It has all the .css files and .js files (and other files) prepared.
Let me know if that helps you out.

Yes, I downloaded .zip file from the webisite.
and I can see all the .css files and .js files.
However, I tried to install it few times, but still the same layout.

I think that your error message is causing the layout to break.
Go into 1 of the other language directories and copy form_validation_lang.php to the english directory. See if that clears up the error.

Thank you very much for the info.
I have managed to run it now.
Seems there are some file permission issues.
It’s up and running now.

1 Like

file permission issues on your server?

Yes, it is on the server,
I have tired it on my computer without problem.

1 Like

It’s too complicated to help you frkm a distance with file permissions.
The last time i had those problems i did this:

sudo find /var/www/your-invoiceplane-path -type f -exec chmod 644 {} \; 
sudo find /var/www/your-invoiceplane-path -type d -exec chmod 755 {} \; 

It will give all files and directories default permissions (755 for directories and 644 for files)

THank you very much .
Actually it all solved from yesterday.

1 Like