V1.6.0 won't run on PHP 8.0.28

I am attempting to install v1.6 on my localhost in a subdirectory with index.php removed.

The v1.6 Requirements page states that PHP >= 8.0 is required. I am running PHP/8.0.28. But, when I try to run the setup (ie. http://localhost/invoiceplane/setup), I get the following message:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.0".

I see that vendor/symfony/deprecation-contracts and vendor/symfony/http-foundation both require PHP >= 8.1.

Is this perhaps a packaging oversight or is the documentation incorrect?

The .zip file on the website was created for PHP 8.1.
If you really want to run InvoicePlane on PHP 8.0 then you can:

  • Remove the vendor directory
  • Remove composer.lock
  • Run composer install

Thank you. That worked.

I think the documentation should mention that as it is reasonable to expect that the package provided would work on PHP >= 8.0.

1 Like

Right, we’ll work on that. Thanks for letting us know

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.