[Solved] Can't add more than 4 products to the invoice

Fist time I’m posting here so first things first thank you for your time and effort to create this software, the open source comunity is one of the most noble movements out there.

I run into a problem though can’t add more than 4 lines of products on the invoice.
I get the message “Record successfully updated” but there is no line added after saving the invoice.
I’m using v1.4.3, apache2, and mysql.
I also activated the log level to 2 there is no errors coming up, every message says loaded succesfully.

Could you please provide some more information:

  • what do you enter in these rows?
  • does your web server itself logs any errors? (Apache error logs)
  • does this bug occurs for one specific invoice or for all? If just for one please add some more information about the invoice.

Thanks for the quick reply I just got in front of a computer.

  1. I have entered products with prices they are just names of products with spaces sometimes.
    When I try add a product from this list or even if I add it manually as soon as I press save it, it appears as if it works then the new lines dissappear.
  2. About apache error logs I’m don’t have access at the server right now but later will check and will inform back.
    I would guess there is nothing wrong all other stuff I got installed works correctly.
    Server is a debian 8.1 no changes to config besides Allow all.
  3. All invoices, even if I delete that one and start a new one problem persists.

What I noticed though is an error when I go on "System settings"
After I change a setting and try saving it I get this message:

I’ve tried both servers mysql-5.5 and mariadb-10 same result.

A Database Error Occurred

Error Number: 1064

You have an error in your SQL syntax; check the manual that corresponds to your MySql server version for the right syntax to use near ') NOT NULL' at line 1

ALTER TABLE `ip_tax_rates` CHANGE `tax_rate_percent` `tax_rate_percent` DECIMAL( 5, ) NOT NULL

Filename: /var/www/html/invoices/modules/settings/controllers/settings.php

Line Number: 35


I also tried to create a new invoice on first boot of the server it did add a new line, after that on an another invoice after saving the lines disappear again.
Please check the apache error log, although nothing happens at the time when I try and add new products to the invoice from the product list created.
There is an error below, "Client denied by server configuration"
That error could be when I tried to download an invoice from the path directly just to check the permissions so not related to my problem.

tail -f /var/log/apache2/error.log

[Tue Aug 11 20:27:05.446395 2015] [core:notice] [pid 997] AH00094: Command line: '/usr/sbin/apache2'
[Tue Aug 11 22:15:59.571855 2015] [access_compat:error] [pid 1051] [client] AH01797: client denied by server configuration: /var/www/html/invoices/uploads/archive/2015-08-11_Invoice_18.pdf
[Tue Aug 11 22:22:30.402610 2015] [mpm_prefork:notice] [pid 997] AH00169: caught SIGTERM, shutting down
[Wed Aug 12 01:59:31.848008 2015] [mpm_prefork:notice] [pid 978] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Aug 12 01:59:32.048555 2015] [core:notice] [pid 978] AH00094: Command line: '/usr/sbin/apache2'
[Wed Aug 12 03:20:57.506231 2015] [mpm_prefork:notice] [pid 978] AH00169: caught SIGTERM, shutting down
[Wed Aug 12 07:06:00.065287 2015] [mpm_prefork:notice] [pid 935] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Aug 12 07:06:00.115458 2015] [core:notice] [pid 935] AH00094: Command line: '/usr/sbin/apache2'
[Wed Aug 12 19:31:57.402376 2015] [mpm_prefork:notice] [pid 916] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Aug 12 19:31:57.412050 2015] [core:notice] [pid 916] AH00094: Command line: '/usr/sbin/apache2'

The 'client denied by server configuration' errors are similar to this problem. I added a link for a solution so maybe you could check if this solves the errors even if I don’t think that it’s directly related. Just to make sure.

I did try and replicate the error, that is not the problem.
Seems like like there is something more to it.
Like I mentioned above that error comes from me trying to download from the direct path.
I was trying to check the permissions “what if I try and download directly will it let me do it” kind of thing.

Command invoked:
–2015-08-13 06:58:37--
Connecting to… connected.
HTTP request sent, awaiting response… 403 Forbidden
2015-08-13 06:58:37 ERROR 403: Forbidden.

error log:
Thu Aug 13 06:58:37.245258 2015] [access_compat:error] [pid 1541] [client] AH01797: client denied by server configuration: /var/www/html/invoices/uploads/archive/2015-08-11_Invoice_18.pdf

Could you please try to make this folder writable?

Downgrading to previos release of debian “wheezy” so far seems to work fine.

Thank you again for your help and the great software.
Soon, possibly next week I’m deploying this live.

Okay, thanks for the information.
Could you please share your exact OS version before and after?

Seems like there i some kind of incompatibility between this software and debian jessie 8.1 which has newer web server, newer php.
So far seems to work fine on an older version of debian wheezy 7.8

I hope this helps.
Thank you

Thank you. I’ll take a look this.