New Install / Upgrade to v 1.1 not working

I tried an upgrade from v. 1.0.2 to v 1.1, following the upgrade instructions, but when I type the url for setup, I get a 404 error.

I then tried a new install of v. 1.0.2 and was able to install successfully.

Did I miss out on anything?

Did you copied the .htaccess file?

Edit: you can also try to remove or alter RewriteBase / in the .htaccess file if you want to install in a sub-directory.

I’ll try looking into the htaccess file. My thoughts are: why won’t it work with v1.1 when the previous versions installed without problems in the same directory struture. Is there anything different in the htaccess file?

Yes we added a line to the .htaccess file for a feature in the setup coming in one of the next versions.

Could you specify on what location is the .htaccess file that need to be copied from?. Are you refering to this content from another post?

# Remove index.php
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Additionally, I do not have any “setup.php” file you mention on the update intructions. I am trying to upgrade from FusionInvoice 1.3.4 could that be it?

I found one setup.php on
according to update instuctions file appears to be at the top level.

Hope this make sense as the update instructions are bit… mmh!!

Thanks for any help

there is just one(!) .htaccess file in the root folder. Nowhere else. If you have problems remove the RewriteBase / line from this file.

And you should not open setup.php but
If yiu upgrade drom FusionInvoice yiu have to follow tge migration instructions. Did you do that?

Hi Kovah
Thanks mate, that was a quick reply. I was actually following the instructions for Update and probably that is the problem. I will try the Migration tool and see how I go.

Thanks again and keep up the good work.

May I make a suggestion, in every systems we should have a recovery tool. Meaning a Recovery Section inside the system (for Backups and Restores). Perhaps adding a drop down “Recovery” Next to Reports with backups and Restore options.

Don’t not much about PHP but quite a bit on DBA issues, please let me know if I can help.

I commented out the RewriteBase / line and installation went through ok Thanks!

Hi Kovah,
I have downloaded and applied the Migrationtool-master. Let me present a bit of what I have to make it more clear.
My structure in the web server is:
/domains (top level)
/domains/domain1.tld (FusionInvoice)
/domains/domain2.tld (other web app)
/domains/domain3.tld (other web app)

Content of folder domain1.tld is:
\aanewver (I have placed here the uncompressed content of Migrationtool-master)

I have also modified the file config.php adding the line:
const SUBDIR = ‘aanewver/’;

Now on the web browser normally I access FusionInvoice with

Therefore to run the Migrationtool-master I issue:

That comes back with a screen

"InvoicePlane DB Conversion Tool"
You can use this tool to convert your existing FusionInvoice Database to InvoicePlane.

Press start and follow the instructions:

When pressing Start it comes back with

Not Found

The requested URL /aanewver/step/config was not found on this server.

What am I doing wrong? it is definetely looking for a folder step and config that I don’t have.
Is it the fact that I have added the migration tool one folder below the top?

Any hints?

Could you please open a new topic in the “Migration Tool” section with this? Just to not mix things up.

Thanks I have opened the new topic.