[Migrationtool] Migration Tool Problem

Hi Kovah,
I have downloaded and applied the Migrationtool-master tool in order to Migrate FusionInvoice v1.3.4 to InvoicePlane. However I’ve encountered some problems and I’m asking for some help.

Please let me present a bit of what my current setting is to make it more clear.
My directory structure on the web server is:
/domains (top level)
/domains/domain1.tld (FusionInvoice)
/domains/domain2.tld (other web app)
/domains/domain3.tld (other web app)

Content of folder domain1.tld is:
\aanewver (I have placed here the uncompressed content of Migrationtool-master)

I have also modified the file config.php adding the line,as instructed:
const SUBDIR = ‘aanewver/’;

At web browser normally I access FusionInvoice using:

Therefore to run the Migrationtool-master I issue as follows:

That start the tool ok and comes back with a screen as follows:

"InvoicePlane DB Conversion Tool"
You can use this tool to convert your existing FusionInvoice Database to InvoicePlane.

Press start and follow the instructions:

When pressing Start it comes back with a screen as follows:

Not Found

The requested URL /aanewver/step/config was not found on this server.

What am I doing wrong? it is definetely looking for a folder step and config that I don’t have.
Is it the fact that I have added the migration tool one folder below the top?

Any help will be apreciated.



First it would be important to know if you copied the .htaccess file to the aanewver/ directory?

Second there is no need for a folder called setp/config as the script itself handles the complete url. But i’ll rewrite this the next days so the script can run without .htaccess and so on.

<<First it would be important to know if you copied the .htaccess file to the aanewver/ directory? >>

Nope I haven’t, in the instructions there was nothing indication that I should do that. I gather I have to do it.

I’ll try again using this file and see if it solves the problem.

Hi again
I have copied the .htaccess to aanewver/ location with the following content:
# Remove index.php
RewriteEngine on
RewriteBase /aanewver
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

After re-run the Migration Tool the problem persist. The output message is:
“Not Found
The requested URL /aanewver/step/config was not found on this server.”

I’ve try with different web browsers (FireFox & Chrome) and clean up the cache just in case but to no avail.

Not sure what else I can try, I’ll wait for any help or suggestions.

Hi everyone

malypetu, did you already found a solution to this topic?

I’m in the very same situation.

digging around found that in file “/content/start.php” in fact there is a reference to that directory “step/config” that is not found.

hope this may help to find a solution.

thank you

Hi There
Yes I have solved the problem, in fact what I’ve done is I wrote an installation guide that covers this and other issues as well, I can email it to you as I don’t know how to upload here.

email me at malypetu@gmail.com and I reply back with the doco maybe you can find the way to make it public.


This is the official documentation:https://github.com/InvoicePlane/InvoicePlane/wiki/Migrate-from-FI
And don’t forget to copy the .htaccess file and make sure mod_rewrite is enabled on your server.

Hello again.

So far I haven´t been able to migrate from Fusion Invoice 1.3.4 to Invoice Plane. Malypetu very kindly provided me his documentation but is mostly for linux servers and . Is it possible to have a more detailed, step by step or how to guide covering even the obvious details to convert the database for users in windows environment with IIS 8.5, mysql 5.6 and php 5.3.28.

Thank you very much again in advance.

Basically there is no difference between Linux and Windows servers because the only operations that happen are related to the MySQL database.
If you are familiar with SQL I could send you the SQL scripts to run them on your server.

Thank you Kovah

Your speed is ten times mine. My respect.

Not too familiar with SQL but send them anyway. I’ll managed to make them work. Very interested to go migrate to Invoice Plane.


Please email me to membrecias@familiavip.com the mentioned scripts. Sorry about that.

Thank you

Here you go: https://github.com/InvoicePlane/Migrationtool/blob/master/sql_commands.sql

Thank you Kovah. Does this script work with MySQL also?

This is a MySQL script. If may not work for MS-SQL or other SQL servers.

Hi Kovah.

Still no success migrating from FI to IP but with all due respect two things about the script for your consideration. Please keep in mind I’m no expert in this area.

For some reason in order to properly execute the commands via MySQL Workbench had to remove " before and after every table name.

and in line 37 (UPDATE fi_custom_fields) came with an error. I believe because that table was already renamed. When changed to ip_custom_fields ran OK.

Give it a look

Thank you