Database Error well after successfull installation

So I’ve been using Invoice Plane on a sub-directory for well over 3 months now. Out of knowhere I decide to go to it to today to edit a quote I made 1 week ago, and it gives me this error:

A Database Error Occurred

Unable to connect to your database server using the provided settings.

Filename: /home/enlitely/public_html/leaf/third_party/MX/Loader.php

Line Number: 99

The database is there, and is up and running. I did nothing to Invoice Plane it was working last time I checked. I just tried updating it to the newest version, NOT deleting the database.php file, and its giving me the same error. I just recently received a payment through it 3 days ago, and now I can’t even login. Can anyone tell me what might be going wrong, and how to fix it? Thanks.

Please check the configuration in the file /application/config/database.php. The credentials for your database are stored there. Correct them if needed.

Did you open after updating to a newer version?

If you have access to the command line try connecting to the database with

mysql -h databasehost -u username -p ENTER

replace the databasehost and username with the values from your database.php config file. After pressing enter you will be prompted for the password. If this fails, try restarting the database server.

You may also use the search here to find some posts about similar errors (use Line Number: 99 as search term). Maybe something there might be helpful.

I will try to resolve this issue with your guys’ recommendations. Thanks I’ll let you know if its fixed. Also I LOVE invoice plane, amazing job on it! It is really awesome. I’d love for the ability maybe in the near future, to add a logo to the invoices/quotes pdf. Possibly even ability to style the online link for quotes and invoices. In any event, still even the best web software I’ve used to date.

The database credentials are correct. I even logged into phpmyadmin, and all the tables look like they are untouched and working. I’ve tried updating via /setup, I get all the way tothe database option and click continue, and it gives me the same error.

how can i download the database.php