Bug in client view page (v.1.43 and 1.44)

Steps to replicate issue:

  • Navigate to a client details page (Clients > View Clients)
  • Click on a client's name
  • Click on the "Invoices" Tab
  • Click on the "Options" Button

When you click on the “Options” button, the dropdown is obscured within the bounding box of the row: the box subsequently develops a scroll bar. Clicking one of the scroll controls causes the button popup to disappear - and the scroll bar disappears too… This bug is present in v1.43 and v1.44.

I have tested this in Firefox (43) and Internet Explorer (11) on Windows 10 - with the same result each time. It is possible to use the mouse-wheel to scroll without causing the popup to collapse, and you can still access all of your invoices via the Invoices menu.

It’s not a showstopper, as there are two easy workarounds - it’s more about the aesthetic; I’ve not managed to cause anything else to break (a professional hobby).

Regards and Thanks for an excellent product!

I have tested this myself in IE 11.0.9600.18015 and FF 42 & 43.0.1 and Chrome. I was not able to replicate this problem on any of these browsers. That was on Windows 7. On a different Windows 10 box, I tested the same thing with FF 43.0.1. I was not able to replicate. I am using v1.4.4.

Have you cleared your cache?

Thank you for your reply. How very strange. Yes, I have cleared my cache (though a cache wouldn’t persist across IE and Firefox…). Are you going in to a “Client”, then clicking the client’s Invoices Tab, then clicking the “Options” Button (e.g. path is https://baseurl/clients/view/3)? The options button works on the main “Client List” page, but not within the actual client file.

I have also tried on another W10 machine, and an Ubuntu machine.

Machine 1, Win10, FF43.0.3, IE: 11.0.10240.16603
Machine 2, Win 10, FF43.0.2, IE 11.20.10586.0 (tested 1.4.4 only)
Machine 3: Ubuntu 14.04, FF 35.0.1 (tested 1.4.4 only)

All display the same behaviour. The 1.4.3 and 1.4.4 installations were on different machines, but I don’t have immediate access to my 1.4.3 machine to test with Machines 2 and 3. The issue is most definitely evident across browsers.

Just tested Iceweasel 38.4.0 (Raspberry Pi) with 1.4.4 - same issue.
clip from Win10, FF43.0.3)

I can reproduce this bug.
However, I’m rewriting the whole layout and markup and this problem should be solved with version 2.

OK, Thank you. It’s an irk more than a bug - I’m interested to see what IP2 brings…

Here’s the info post about IP 2: https://blog.invoiceplane.com/2016/01/03/58

1 Like