Unsuccesfull installation

hello there,

I have been trying for the last three hours to install Invoice Plane in a Synology Server.
I followed up the tutorial, and amended the .htacces file to match my path.
But I get these message:
An Error Was Encountered
Unable to load the requested class: session

.htaccess file:

Remove index.php

RewriteEngine on
RewriteBase /invoiceplane
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

And as far as I can see, the Apache server allows rewrite:

Would you please help me to solve this issue, and tell me what I am doing wrong.
I went through the forum and did not find any similar issue.

Thank you for your help.

Pierre Souchar

Did you upload all the files?Is InvoicePlane really in /invoiceplane?

Thank you for your reply !
Yes, everything seems to be there.
I have installeit again, but now I reveice another message, saying that the page ca not be found.

I have installed by tha past WP and another invoice app (simple invoice) without trouble.

Thank you again,

Pierre S

As I can see, your .htaccess file is already in the invoiceplane directory. Change line 4 in your .htaccess file an try again.

RewriteBase /

Thank you,

But is it line 4 or line 3 ?
Here is what is in my htaccess file:

Remove index.php

RewriteEngine on
RewriteBase /invoiceplane
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Should I delete “/invoice” in line 3 ?
And if it is in line 4, what should I modify…?
My knowledge is quite limited … Sorry !

Or another try, that I did, but did not work is to put the .htaccess in the root folder (“web” in the picture) and leave “/invoice”.

Again, thank you so much for your help !



And I have verified mcrypt, and it is enabled.

Any other suggestion?

Many thanks in advance !


Pierre Souchar

How do you doing to install this invoice system to your server?
Did you uploaded the files to the server and then, call setup on url?
something like http://invoiceplane/setup

Or your doing in another way.
And where did you downloaded the files, from invoice plane or on github?
Please try get files from github.

Thank you for your reply.
1.- I downloaded the files from the official site (https://invoiceplane.com/downloads).
2.- I unzipped them and tranfert the hole file to my Diskstation, it is on my network.
3.- I change the name of the file from v1.4.3 to invoiceplane.
4.- I modify the .htaccess file with the name of the file “/invoiceplane” in line 3. For this I have to doanload the file from my Diskstation, modify it in Textedit (Notepad equivalent for Mac) and then transfer it again to my Disksattion.
5.- Put the address on my browser.
6.- Get the white page with “Sorry, we can’t find your page”

I did another yesterday and I managed to install the application at the root of my web folder but there were a lot of files from the appplication folder and another folder that had permissions problems.
I could sove them case by case and I finally open the application.
1.- I could not get a pdf from it. ALL that I get was a blanck browser page when I wanted to create an Invoice in pdf…

Thank you very much for your reply.

Pierre Souchar

In your sample code it was line 4 now it’s line 2. :smiley:

Is the “Sorry, we couldn’t find your page” written in blue without any other information? If yes this is an issue related to the Diskstation web server itself and not InvoicePlane. You should check the Diskstation help then.

Thank you Kovah,

It might be Diskstation issue, but:
How come I can install Wordpress and Simple Invoice without problem in it and not Simple Plane?
I followed the instructions and verified every parameters and I can install it at the root of my site (but I can not see the pdf).
I thought that maybe someone had installed it in a Diskstation before, knowing what is the problem between IP and DS.
It is weird that all the other applications worked but not IP !
And I am sure that if I contact DS service they will tell me to contact the IP developers…
“the snake bits it tails” as we say in French…



Just to test this:

  1. Remove the .htaccess file
  2. Change $config['index_page'] = ''; to $config['index_page'] = 'index.php'; in the /application/config/config.php file.
  3. Open

If this is not working it is not a problem related to InvoicePlane.

1 Like

I had the same issue when tried to install for the first time, and this solution solved my problem.
Thanks so much Kovah.