Internal Server Error .htaccess

after edit .htaccess file Internal Server Erro

also whene i disable .htaccess

i see this message

An Error Was Encountered
The configuration file database.php does not exist.

Did you followed the installation instructions from the wiki?
“The configuration file database.php does not exist” is shown when the application is not installed yet.

yes i did instructions from the wiki

also i see [Solved] Installation Help

yes still not installation yet just Upload file on my serves

did you started the installation? Because the installation creates a database.php configuration file.

when i try installation

1 i up Uploads file

2 edit .htaccess file

i try to installation but i see this messege Internal Server Erro

I also have the same problem. I have performed the following steps:

  1. Changed my htaccess file to read:

    RewriteEngine on
    RewriteBase /invoicedemo
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule . index.php [L]

  2. Renamed htaccess file to .htaccess

  3. Changed $config[‘index_page’] = ‘index.php’; to $config[‘index_page’] = ‘’;

I get an “Internal Server Error” when I go to

If I dont rename htaccess to .htacess, I get a “Page Not Found” error

What am I missing or doing wrong?

To solve these type of errors it’s necessary to take a look at the server error logs. Every internal server error should be logged there.

I’ve checked the error logs and it is empty

Please try it again with the debug mode turned on.

still not fix it :frowning:

when you run the setup make sure you are giving right path.

For Running Setup Correctly you should run setup like this you copy your InvoicePlanneApp) /index.php/setup

Make sure you give index.php also when you run setup.

I hope that works. I did that way it works.


You are not forced to use the .htaccess file. It is disabled by default within InvoicePlane 1.4.6.
Please remove the file or rename it and try again.