Unable to install No matter what I do


I have tried installing Invoiceplane v1.4.4 on both my Synology NAS as well as MAMP on my Mac and each time, I have totally failed. I have followed every solution offered but to no avail.

I have followed the instructions exactly, but I will get the 404 error if I type in my domain

http://localhost/Invoice which is the subfolder. My .htaccess file has been modified as per the installation instructions and yet noting.

If I type http://localhost/Invoice/setup, I get the error that
The requested URL /index.php was not found on this server.

I am at my wits end and hope someone can help me get through this.



Could you please post the content of your .htaccess file?

My htaccess file is as follows:

RewriteEngine on
RewriteBase /Invoice
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule . index.php [L]

Okay the .htaccess looks good. Are you 100% sure that mod_rewrite is enabled in your host and NAS? And is AllowOverride All set in the global config?
It seems like the .htaccess is just ignored…

I am now using MAMP Pro to try. Checked Mod rewrite in Apache and it is enabled.

In httpd.conf, LoadModule rewrite_module modules/mod_rewrite.so is also enabled, not commented out.

Still not able to get through installation.

When I try to run setup, I find these .htaccess files in the folders. content as such. Does it mean my Apache is still blocking?

/Applications/MAMP/htdocs/Invoice/system/.htaccess ; exit;
Walter-Wus-Mac-Pro:~ waltwu05$ /Applications/MAMP/htdocs/Invoice/system/.htaccess ; exit;
/Applications/MAMP/htdocs/Invoice/system/.htaccess: line 1: Deny: command not found

[Process completed]

Any help? Anything I am doing wrong?

Please use this small guide to disable the .htaccess functionality.