Incorrect decimal value

The error logs give nothing pretty much, just a 500.0 IIS error which equates to 500.0 - Module or ISAPI error occurred.

I had to make my own web.config file to do the friendly url’s the software uses. It worked fine before, I know i am getting alot of 404’s in console from fonts and other things, and then 500’s but i cant find an error log to tell me why im getting the 500.

You can display more informative error messages on ISS. Please follow this guide:

This is all I can get to show.

I upgraded to 1.4.1 by the way.

Yes but we need the web server error logs. As said you have to edit the ISS configuration to display the detailed error messages

The instructions you gave me I know you just googled yourself. I cant really find anything myself. However those instructions are to send the error logs to your browser, which does not seem to work. I still get all the errors about invalid ‘’ for those columns.

??? I can’t find any of these errors in the logs you posted…

Edit: and there error log’s can’t be sent to the browser based on the architecture of the application. Error 500 are only logged within the web server itself, not the browser.

Well then I don’t know how to get IIS to log them to a file, there is not an option for that.

ERROR - 2015-06-11 11:00:18 --> Query error: Incorrect decimal value: ‘’ for column ‘item_discount_amount’ at row 1

This is when I add one item and hit save, if i put a 0 in that field then it will say this.

ERROR - 2015-06-11 11:01:26 --> Query error: Incorrect decimal value: ‘’ for column ‘invoice_discount_amount’ at row 1

If i fill that in, I get this.

ERROR - 2015-06-11 11:01:57 --> Query error: Incorrect decimal value: ‘’ for column ‘invoice_discount_percent’ at row 1

I apologize I could have sworn that was in the original logs I pasted.

These errors make no sense to me, it must be the framework you are using, since the DDL for the table looks fine and has a default set of 0.00

Could you try to simply set the discounts to 0?

Set them 0 where?

As I just explained even If I type them in, the invoice one goes nuts and expects the amount AND percent fields, but of course you cant put both in, the opposite one gets greyed out if one is filled in.

Oh okay sure. Will add a bug report for this.

Is there anything that can be done about this today? I’ve not had a working invoice system for over a week now :S

I will take a look at this.

[size=10]Last Update 21.06.2015 (marked as fixed)[/size]

This issue should be fixed now. Please reply if the issues still comes up after updating.

Kovah ask me to replay here for the error that still exist @ my system after update:

root@webserver:/home/servers# uname -r

root@webserver:/home/admin/public_html/fc/application/logs# cat /etc/*-release
PRETTY_NAME="Debian GNU/Linux 7 (wheezy)"
NAME="Debian GNU/Linux"
VERSION=“7 (wheezy)”

root@webserver:/home/servers# php -v
PHP 5.4.40 (cli) (built: May 13 2015 21:05:23)

root@webserver:/home/servers# mysql -u admin -p -e 'SHOW VARIABLES LIKE “%version%”;'
Enter password:
| Variable_name | Value |
| innodb_version | 5.6.12 |
| protocol_version | 10 |
| slave_type_conversions | |
| version | 5.6.12 |
| version_comment | Source distribution |
| version_compile_machine | x86_64 |
**version_compile_os | Linux **

root@webserver:/home/servers# httpd -v
Server version: Apache/2.4.12 (Unix)
Server built: May 13 2015 20:38:10

root@webserver:/home/servers# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel® Core™2 Quad CPU Q8200 @ 2.33GHz
stepping : 7
cpu MHz : 2000.000

Log file from the begin i press Add invoice to submit invoice:

Maybe the solution are to add default value 0 to discount ?

I hope you have enough information of my server

1 Like

Do you get the exact same error?
Query error: Incorrect decimal value: '' for column 'invoice_discount_amount' at row 1
What exactly do you enter on the discount fields?

With the error i never nothing it works if I enter value 0

You did not fix the other query errors I gave.

ERROR - 2015-06-22 12:38:41 --> Query error: Incorrect decimal value: ‘’ for column ‘item_discount_amount’ at row 1
This one happens if you do not fill in the discount field on the item.

A workaround i’ve been using with Chrome: (same should work in other other’s with dev tools available).

After entering a value for “Discount %”, right click on “Discount $” and remove the “disabled” attribute from the input element, then you can enter a 0 for that field as well.


This one was still never fixed. I just upgraded to the latest release. and still an issue. Can you fix this tiny error?