Upgrade from v1.4.6 to v1.5.9


#1

Hi,
today I have upgraded my IP from the version 1.4.6 to 1.5.9 with php 7.3

I have followed the instructions in the wiki and apparently all goes fine but after the upgrade during the first setup appear the same error message of this post PHP 7.2 upgrade

I have solved as advised from Martin_Anonym, but after this fix during the setup appear a warning:

Attenzione! 
Si prega di aprire il file application/config/config.php e modificare la riga $config ['sess_use_database'] = false; con $config ['sess_use_database'] = true;. 
Maggiori dettagli qui

I have tried to replace the line in the file config.php but the string doesn’t exist.

Could I ignore the message?

Thanks


Error on upgrading from 1.4.6 to 1.5.9
#2

During which setup?
Pls tell us exactly where this warning comes from.

Even if it is “just a warning” it should not get ignored.

Here some questions:

1.) does this warning appear with PHP 7.2?
2.) What if you just add this line ion the config, does the warning dissapear?
3.) have you performed a backup befor upgrading?

Best regards.


#3

The message appear during the setup after the update:

http://your-domain.com/index.php/setup

When I press next after the selection of the language appear a red box with the message:

Attenzione! 
Si prega di aprire il file application/config/config.php e modificare la riga $config ['sess_use_database'] = false; con $config ['sess_use_database'] = true;. 
Maggiori dettagli qui

I reply to your questions:

  1. isn’t a PHP 7.3 message
  2. I haven’t add the line, I have just opened the file application/config/config.php and I have seen that the parameter sess_use_database doesn’t exist. The message box with doesn’t appear in the normal use of IP
  3. yes I have a backup of files and a dump of database

#4

I’ve translated the message…

Please open the application / config / config.php file and edit the line $config [‘sess_use_database’] = false; with $config [‘sess_use_database’] = true ;.

So if you go to /application/config/config.php could you edit those variables?
Or add that line in your /application/config/config.php, that would help


#5

Like @UnderDog said: what if you add this line?

For me this field also does not excists in the config.php.

So there are two options:

1.) try to add the line and see if it dissapears.
2.) try to execute the setup anyway and tell us if it is causing some errors.