Email template for quotes is not working on 1.5.x


#1

Email template for quotes is not working properly. Apparently it is correct when the template is created, but at the time of making use of it, all fields of the sending of the email appear blank.

Instead, for invoices it works.

My installation is made on:

Apache 2.2
PHP 7.0

Regards.

SOLUTION

Tim_Price wrote:

The solution is to edit application/modules/mailer/views/quote.php to remove the single quotes around

<?php echo $email_template ?>

in line 18 (I’m running InvoicePlane 1.5.0).


Quotation email template is not loaded
Template not loading body when sending email
Custom fields of user is not replaced in quotation or invoice mail template
Error in the file dependencies.min.js
HTML Email Template
Uncaught TypeError: Cannot use 'in' operator to search for 'length' in null
Email template not working
#2

It would be very helpful if you could post an example of how your template looks like…


#3

QUOTES


This form should be filled and not empty.

INVOICES

I’ve been using the same template for years.


#4

Ah okay, now I understand the actual problem.

Added a bug report for that: https://development.invoiceplane.com/browse/IP-528


#5

I wish that the problem can be solved in the next actulization 1.5.3

Greetings and thanks for all the effort.


#6

Same here

1.5.2

PHP 7.1

Also tested on PHP 7.0 and 5.6


#7

Are there any errors displayed in the console? You may switch on the debug mode to see some output.


#8

Hello Kovah

DEBUG is on, but no erros on console

Log seens to be ok

If you need, log is attached
log-2017-05-10.php (5.7 KB)


#9

Hi to all.
When I try to send an email of a quote, the <textarea> does not replicate the content of the template selected above.
The javascript console says:

Uncaught TypeError: Cannot use 'in' operator to search for 'length' in null
    at c (dependencies.min.js:1)
    at Function.each (dependencies.min.js:1)
    at inject_email_template (scripts.min.js:1)
    at HTMLDocument.<anonymous> (4:293)
    at j (dependencies.min.js:2)
    at Object.fireWith [as resolveWith] (dependencies.min.js:2)
    at Function.ready (dependencies.min.js:2)
    at HTMLDocument.h (dependencies.min.js:1)

Could I have made a mistake in the template settings?
(sorry for my pedestrian english)


#10

Hi everyone,

The solution is to edit application/modules/mailer/views/quote.php to remove the single quotes around

<?php echo $email_template ?>

in line 18 (I’m running InvoicePlane 1.5.0).

I found this by comparing the code in invoice.php (which works) with quote.php (which doesn’t).

Anyway, now the template text is copied to my quote emails correctly…


#11

Good news!

I’ll try tomorrow with your solution.

Regards.


InvoicePlane 1.5.2 released
#12

Congrats!! Email template for quotes is working again.

Thank’u so much.

Cheers.


#13

This issue has been fixed in v1.5.3 https://development.invoiceplane.com/browse/IP-528


#14

Hey Guys,

I’ve tried all of the above and I’m still having the same issue.

Any other fixes?

Cheers

Dale


#15

Hi to all.
I tried this solution and all works fine.
Thanks a lot.


closed #16