403 Forbidden / Permissions / Access


#1

I really hope you guys can help me out with this. It was working before I don’t know what happened. Thanks for your time.

I get the same result with 10.0.0.6/invoice
However, I can access my personal website and 10.0.0.6/movies

Here is my htaccess file,

<IfModule mod_rewrite.c>

  RewriteEngine On
  RewriteBase /invoice
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . index.php [L]
  
  ## Remove the hash in front of the following two lines if you want to force HTTPS
  #RewriteCond %{HTTPS} off
  #RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
  
</IfModule>

Here is a snippet from my apache.conf

<Directory /home/dan/www/>
       Options Indexes FollowSymLinks
       DirectoryIndex Index.html
       AllowOverride All
       Require all granted
</Directory>

<Directory /home/dan/www/website/invoice/>
       Options Indexes FollowSymLinks
       AllowOverride All
       Order allow,deny
       Require all granted
</Directory>

#2

Did you tried accessing the site without having .htaccess enabled? It is not required to run the app.

Also, did you correctly entered your domain in the index.php file?


#3

Hey Kovah,

I edited my apache.conf to look like this.

<Directory /home/dan/www/>
       Options Indexes FollowSymLinks
       AllowOverride All
       Order allow,deny
       Require all granted
</Directory>

#    <Directory /home/dan/www/website/invoice/>
#          Options Indexes FollowSymLinks
#          AllowOverride All
#           Order allow,deny
#           Require all granted
#    </Directory>

I can view my dashboard.


#4

The goal was to be able to access my dashboard outside my network. In my config.php, I have this line as my base URL:

$config['base_url'] = 'http://10.0.0.6/invoice/';

If my local IP is set here I will never be able to accomplish this. What needs to be done?


#5

If you want to access your local machine from outside of your network you need Dynamic DNS:
https://www.google.de/?q=dynamic+dns


#6

Kovah,

Here, I will be more clear, I actually have my site registered already. While outside my network, the furthest I can get is mydomain.com/invoice. If I go to mydomain.com/invoice/dashboard I get 403 permission denied.

Thank you


#7

Have you set mydomain.com in the index.php file?
Does mydomain.com/invoice/index.php/dashboard works?


#8

So, I set the 18th line in my config.php to:

$config['base_url'] = '/invoice';

I set the server’s local IP to its DNS name in the host file of my windows pc.

it solved my problem. Thanks


Access InvoicePlane through different computer with same network
closed #9